Skip to main content
CVE-2025-3277VulnerabilityPublished Updated

SUSE · security update for nodejs

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-3277· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium · fixed in SUSE package updates : update SUSE when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.2% chance of exploitation in 30 days – higher than 69% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2, 10.1, 10.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:L/SI:L/SA:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SUSE to 10.2, 10.1 or 10.0.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=10.0 <10.1
  • >=10.0 <10.2
  • >=9.0 <10.0
Fixed in
  • 10.1
  • 10.2
  • 10.0

AI-suggested

Red Hat has released an official security update that addresses these vulnerabilities. Users should apply the provided update for the nodejs:22 module on Red Hat Enterprise Linux 9 and 10 variants as detailed in the Red Hat advisory RHSA-2025:7433. No additional mitigation steps are required beyond applying this update.

Description

Red Hat has released an important security update for the nodejs:22 module addressing two vulnerabilities: a use-after-free in c-ares (CVE-2025-31498) and an integer overflow in SQLite (CVE-2025-3277). These vulnerabilities affect Node.js as packaged in Red Hat Enterprise Linux 9 and 10 variants. No known exploits are reported in the wild at this time. The update mitigates these issues and is recommended to be applied promptly.

References

Community reviews

Loading reviews…