Skip to main content
CVE-2025-22150VulnerabilityPublished Updated

Red Hat Security Advisory: nodejs:22 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 22.13.1 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 22.13.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 22.13.1.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=22.0.0 <22.13.1
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux AppStream (v. 8)
  • src
  • nodejs-1:22.13.1-1.module+el8.10.0+22759+46b58560.src::nodejs:22
Fixed in
  • 22.13.1

AI-suggested

Red Hat has released updated Node.js 22 packages for Red Hat Enterprise Linux 8 that address these vulnerabilities. Users should apply the security update RHSA-2025:1611 as detailed in the Red Hat advisory (https://access.redhat.com/errata/RHSA-2025:1611) and the update instructions (https://access.redhat.com/articles/11258). No additional mitigation steps are specified or required beyond applying the official update.

Description

Red Hat has issued a security advisory for Node.js 22 on Red Hat Enterprise Linux 8 addressing three vulnerabilities: insufficient randomness in the undici HTTP client (CVE-2025-22150), worker thread exposure via the diagnostics channel (CVE-2025-23083), and a memory leak caused by GOAWAY HTTP/2 frames (CVE-2025-23085). These issues have been rated with an important security impact. The advisory provides updated packages to remediate these vulnerabilities.

References

Community reviews

Loading reviews…