Skip to main content
CVE-2026-56846VulnerabilityPublished Updated

Red Hat Security Advisory: nodejs22 security update

Affects Red Hat nodejs22Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-56846· High 7.5

Not known to be exploited · CVSS 7.5 High.

Data as of 2 Nov 2026, 12:32 UTC

CVSS 3.0 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
nodejsnodeAffected
  • >=24.18.0 <=24.18.0
  • >=22.23.1 <=22.23.1
Fixed in–
npmnodepkg:npm/nodeOther threatsAffected
  • =24.18.0
  • =22.23.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated nodejs22 packages (version 22.23.2-1.el10_2) that address these vulnerabilities. Users of Red Hat Enterprise Linux 10 and its variants should apply the provided security update promptly. For detailed update instructions, refer to Red Hat's official article at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official update.

Description

Red Hat has issued a security advisory for nodejs22 addressing multiple vulnerabilities in Node.js, including unauthorized filesystem access due to a permission model enforcement flaw, remote memory exhaustion via HTTP/2 retained header blocks, and a heap-use-after-free in HTTP/2 handling that can cause denial of service. These vulnerabilities affect Node.js as packaged in Red Hat Enterprise Linux 10 and related variants. The update is rated as Important by Red Hat Product Security.

References

Community reviews

Loading reviews…