Skip to main content
CVE-2026-27622VulnerabilityPublished Updated

Red Hat Security Advisory: OpenEXR security update

Affects Red Hat OpenEXRSource GCVE Database

0
Compare
Authoritative record:CVE-2026-27622· High 8.4

Not known to be exploited · CVSS 8.4 High · fixed in Red Hat package updates : patch Red Hat openexr soon.

Data as of 5 Nov 2026, 21:17 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.4.6, 3.3.8, 3.2.6
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade openexr and academysoftwarefoundation/openexr to 3.4.6, 3.3.8 or 3.2.6.

Affected software

ProductAffectedFixed in
AcademySoftwareFoundationopenexrAffected
  • >=3.4.0 <3.4.6
Fixed in
  • 3.4.6
AcademySoftwareFoundationopenexrAffected
  • >=3.3.0 <3.3.8
Fixed in
  • 3.3.8
AcademySoftwareFoundationopenexrAffected
  • >=2.3.0 <3.2.6
Fixed in
  • 3.2.6
GitHubacademysoftwarefoundation/openexrpkg:github/academysoftwarefoundation/openexrOther threatsAffected
  • <3.2.6
  • >=3.2.6 <3.3.8
  • >=3.3.8 <3.4.6
Fixed in
  • 3.2.6
  • 3.3.8
  • 3.4.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated OpenEXR packages for Red Hat Enterprise Linux 8.6 variants to fix this vulnerability. Users should apply these official updates as described in the Red Hat advisory (RHSA-2026:12339) to remediate the issue. Refer to https://access.redhat.com/articles/11258 for update instructions.

Description

An integer overflow vulnerability in OpenEXR's EXR file processing can lead to arbitrary code execution. This security issue affects the OpenEXR libraries used in Red Hat Enterprise Linux 8.6 variants. Red Hat has issued an important security advisory and released updated packages to address this flaw.

References

Community reviews

Loading reviews…