Skip to main content
CVE-2025-13601VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Container Platform 4.17.49 bug fix and security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-13601· High 7.7

Not known to be exploited · CVSS 7.7 High : upgrade the Red Hat redhat/glib package to 10.2 or 9.8 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.7High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.2, 9.8
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/glib package to 10.2 or 9.8.

Affected software

ProductAffectedFixed in
Red Hatredhat/glibpkg:rpm/redhat/glibOther threatsAffected
  • =0
  • >=9.0 <9.8
  • >=10.0 <10.2
Fixed in
  • 9.8
  • 10.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Red Hat OpenShift Container Platform version 4.17.49. All users running versions >=4.17.0 and <4.17.49 are strongly advised to upgrade to 4.17.49 using the OpenShift CLI (oc) or web console. Detailed upgrade instructions are provided by Red Hat in their official documentation. No additional mitigation steps are indicated beyond applying this update.

Description

This update for glib2 fixes the following issues: Update to version 2.84.4. Security issues fixed: - CVE-2025-14512: integer overflow in the GIO `escape_byte_string()` function when processing malicious files or remote filesystem attribute values can lead to denial-of-service (bsc#1254878). - CVE-2025-14087: buffer underflow in the GVariant parser `bytestring_parse()` and `string_parse()` functions when processing attacker-influenced data may lead to crash or code execution (bsc#1254662). - CVE-2025-13601: heap-based buffer overflow in the `g_escape_uri_string()` function when processing strings with a large number of unacceptable characters may lead to crash or code execution (bsc#1254297). - CVE-2025-7039: integer overflow when creating temporary files may lead to an out-of-bounds memory access that can be used for path traversal or exposure of sensitive content in a temporary file (bsc#1249055). Other issues fixed and changes: - Fix GFile leak in `g_local_file_set_display_name` during error handling. - Fix incorrect output parameter handling in closure helper of `g_settings_bind_with_mapping_closures`. - `gfileutils`: fix computation of temporary file name. - Fix GFile leak in `g_local_file_set_display_name()`. - `gthreadpool`: catch `pool_spawner` creation failure. - `gio/filenamecompleter`: fix leaks. - `gfilenamecompleter`: fix `g_object_unref()` of undefined value.

References

Community reviews

Loading reviews…