Skip to main content
CVE-2025-6021VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Container Platform 4.12.80 bug fix and security update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-6021· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat to 2.14.4 soon.

Data as of 1 Nov 2026, 12:17 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.14.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 1 Nov 2026.

What to do

Upgrade libxml2 to 2.14.4.

Affected software

ProductAffectedFixed in
libxml2Affected
  • <2.14.4
Fixed in
  • 2.14.4

AI-suggested

Users of Red Hat OpenShift Container Platform 4.12 should upgrade to version 4.12.80 or later, which contains the fixed container images and RPM packages addressing these vulnerabilities. Upgrades can be performed using the OpenShift CLI (oc) or the web console. Detailed upgrade instructions are available in the official Red Hat documentation. No alternative mitigations are indicated; applying the update is the recommended action.

Description

Red Hat OpenShift Container Platform 4.12.80 includes important security updates addressing multiple vulnerabilities in components such as libxslt, git, and libxml2. These issues include heap use-after-free, arbitrary code execution, integer overflow leading to stack buffer overflow, and out-of-bounds reads. Users of OpenShift Container Platform 4.12 are advised to upgrade to the updated packages and container images to mitigate these vulnerabilities.

References

Community reviews

Loading reviews…