Skip to main content
CVE-2025-5987VulnerabilityPublished Updated

Red Hat Security Advisory: OpenShift Container Platform 4.16.56 bug fix and security update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2025-5987· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade Red Hat to 0.11.2 soon.

Data as of 5 Nov 2026, 18:06 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.18.1
Patch
Available – fixed in 0.11.2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade libssh to 0.11.2.

Affected software

ProductAffectedFixed in
libsshAffected
  • >=0.10.0 <0.11.2
Fixed in
  • 0.11.2

AI-suggested

Red Hat OpenShift Container Platform 4.16 users should upgrade to version 4.16.56, which includes the updated container images and packages that fix these vulnerabilities. Updates can be applied using the OpenShift CLI (oc) or the web console. Detailed upgrade instructions are available in Red Hat's official documentation. No additional mitigation actions are indicated beyond applying the update.

Description

Red Hat OpenShift Container Platform 4.16.56 includes security fixes addressing two vulnerabilities: CVE-2025-5987 in libssh related to an invalid return code for chacha20 poly1305 with the OpenSSL backend, and CVE-2025-9714 in libxslt/libxml2 causing infinite recursion in a dynamic function. These issues have been rated as moderate severity by Red Hat Product Security. Users of OpenShift Container Platform 4.16 are advised to upgrade to the updated packages and container images when available via the appropriate release channels.

References

Community reviews

Loading reviews…