Red Hat Security Advisory: OpenShift Container Platform 4.16.64 bug fix and security update
Affects Red HatSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 6.7 Medium : upgrade the Red Hat redhat/libcap package to 10.2 or 9.8 when convenient.
Data as of 29 Oct 2026, 10:37 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 10.2, 9.8
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 9 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade the Red Hat redhat/libcap package to 10.2 or 9.8.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/libcappkg:rpm/redhat/libcapOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Users of Red Hat OpenShift Container Platform 4.16 should upgrade to version 4.16.64 or later as soon as the updated packages and container images are available in their release channel. Upgrades can be performed using the OpenShift CLI (oc) or web console following Red Hat's official cluster update documentation. No additional mitigations are specified beyond applying the official update.
Description
Red Hat OpenShift Container Platform 4.16.64 includes multiple security fixes addressing privilege escalation, denial of service, use-after-free, and out-of-bounds read vulnerabilities in components such as libcap, OpenSSH, jq, rsync, and the Linux kernel. Users of OpenShift Container Platform 4.16 are advised to upgrade to these updated packages and container images to mitigate these issues.
References
- access.redhat.com/errata/RHSA-2026:25044 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2451615 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2454469 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2458077 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2458084 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2458898 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2464351 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2477015 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_25044.json (opens in a new tab)