SUSE · security update for openssh
Affects SUSESource GCVE Database
Not known to be exploited · 27% EPSS : upgrade to 9.0.3 when convenient.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 27.9% chance of exploitation in 30 days – higher than 98% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 9.0.3
Exploitation evidence
Disclosed: evidence found.
CVE published 10 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade SUSE to 9.0.3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
Red Hat has released official security updates that address this vulnerability for Red Hat Enterprise Linux 9 and related products. Users should apply these updates promptly. For detailed update instructions, refer to Red Hat's advisory and knowledge base article at https://access.redhat.com/errata/RHSA-2024:4457 and https://access.redhat.com/articles/11258. Since an official fix is available, applying the vendor-provided patches is the recommended mitigation.
Description
CVE-2024-6409 is a race condition vulnerability in OpenSSH server's signal handling that may allow remote code execution by an unprivileged user. The issue occurs when the sshd process handles a SIGALRM signal asynchronously during authentication timeout, invoking non-async-signal-safe functions like syslog(). This affects OpenSSH versions from 9.0 up to but not including 9.0.3. Red Hat has released security updates addressing this flaw for Red Hat Enterprise Linux 9 and related products. No known exploits are reported in the wild.
References
- access.redhat.com/errata/RHSA-2024:4457 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2295085 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_4457.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2024:4716 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_4716.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_4457.json (opens in a new tab)
- suse.com/security/cve/CVE-2024-6409/ (opens in a new tab)