Skip to main content
CVE-2025-59830VulnerabilityPublished Updated

Red Hat Security Advisory: pcs security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 10.1 or 8.7 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.5% chance of exploitation in 30 days – higher than 47% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 10.1, 8.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 10.1 or 8.7.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=10.0 <10.1
  • >=8.6 <8.7
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux High Availability (v. 10)
  • noarch
  • cockpit-ha-cluster-0:0.12.0-3.el10_0.3.noarch
  • Red Hat Enterprise Linux High Availability E4S (v.8.8)
  • Red Hat Enterprise Linux High Availability TUS (v.8.8)
  • src
  • Red Hat Enterprise Linux High Availability E4S (v.8.6)
  • Red Hat Enterprise Linux High Availability TUS (v.8.6)
  • Red Hat Enterprise Linux High Availability AUS (v.8.4)
  • Red Hat Enterprise Linux HighAvailability EUS EXTENSION (v.8.4)
  • Red Hat Enterprise Linux High Availability (v. 9)
  • Red Hat Enterprise Linux Resilient Storage (v. 9)
  • cockpit-ha-cluster-0:0.12.1-1.el10_1.1.noarch
Fixed in
  • 10.1
  • 8.7

AI-suggested

Red Hat has released security updates that fix these vulnerabilities. Users should apply the provided patches and updates as detailed in the Red Hat advisories RHSA-2025:19513 and RHSA-2025:19734. The advisories include updated package versions for affected Red Hat Enterprise Linux High Availability releases. Applying these official fixes will mitigate the described security issues.

Description

The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * rubygem-rack: Rack QueryParser has an unsafe default allowing params_limit bypass via semicolon-separated parameters (CVE-2025-59830) * rack: Rack's unbounded multipart preamble buffering enables DoS (memory exhaustion) (CVE-2025-61770) * rack: Rack's multipart parser buffers large non?file fields entirely in memory, enabling DoS (memory exhaustion) (CVE-2025-61771) * rack: Rack memory exhaustion denial of service (CVE-2025-61772) * rubygem-rack: Unbounded read in `Rack::Request` form parsing can lead to memory exhaustion (CVE-2025-61919) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…