Skip to main content
CVE-2026-4800VulnerabilityPublished Updated

Red Hat Security Advisory: pcs security update

Affects Red Hat pcsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited : upgrade Red Hat pcs to 8.4.11 soon.

Data as of 30 Oct 2026, 06:59 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
2.8% chance of exploitation in 30 days – higher than 86% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.11

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    Public exploit code: GitHub proofs of concept

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Red Hat pcs to 8.4.11.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.4 <8.4.11
  • Red Hat
  • Red Hat Enterprise Linux
  • Red Hat Enterprise Linux High Availability AUS (v.8.4)
  • Red Hat Enterprise Linux HighAvailability EUS EXTENSION (v.8.4)
  • x86_64
Fixed in
  • 8.4.11

AI-suggested

Red Hat has released updated pcs packages (version 0.10.8-1.el8_4.11) that fix these vulnerabilities. Users of Red Hat Enterprise Linux 8.4 High Availability should apply the provided update promptly. Detailed update instructions are available at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory.

Description

The pcs packages provide a command-line configuration system for the Pacemaker and Corosync utilities. Security Fix(es): * tornado-python: Tornado: Denial of Service via large multipart bodies (CVE-2026-31958) * lodash: lodash: Arbitrary code execution via untrusted input in template imports (CVE-2026-4800) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…