Skip to main content
CVE-2024-35176VulnerabilityPublished Updated

Red Hat Security Advisory: pcs security update

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2024-35176· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 8.10.1 when convenient.

Data as of 26 Oct 2026, 07:57 UTC

CVSS base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.0% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.10.1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 16 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade redhat/pcs to 8.10.1.

Affected software

ProductAffectedFixed in
Red Hatredhat/pcspkg:rpm/redhat/pcsOther threatsAffected
  • >=8.0.0 <8.10.1
Fixed in
  • 8.10.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated pcs packages that address this vulnerability. Users should apply the security update as described in Red Hat advisory RHSA-2024:5338 and the related article https://access.redhat.com/articles/11258. Applying this update mitigates the vulnerability. No additional mitigation steps are required beyond installing the official fix.

Description

A low severity vulnerability (CVE-2024-35176) affects the pcs packages used for command-line configuration of Pacemaker and Corosync utilities in Red Hat Enterprise Linux 8. The issue involves a denial of service (DoS) caused by the REXML parser when processing XML attributes containing many '<' characters. Red Hat has released an update to address this vulnerability in multiple Red Hat Enterprise Linux 8 variants, including High Availability and Resilient Storage editions across various architectures. No known exploits are reported in the wild. The update is available and should be applied to affected systems.

References

Community reviews

Loading reviews…