Red Hat Security Advisory: pcs security update
Affects Red Hat pcsSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.0 Critical : upgrade Red Hat tornado to 6.4.1 as a priority.
Data as of 29 Oct 2026, 08:13 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.4.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 15 Sep 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade tornado to 6.4.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| tornadowebtornado | Affected
| Fixed in
|
PyPItornadopkg:pypi/tornadoOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released updated pcs packages (version 0.10.8-1.el8_4.12) for Red Hat Enterprise Linux 8.4 High Availability that address these vulnerabilities. Users should apply these official updates as detailed in Red Hat's advisory and article https://access.redhat.com/articles/11258. No additional mitigations are specified or required beyond applying the update.
Description
Red Hat issued a security advisory for the pcs packages, which configure Pacemaker and Corosync utilities. The update addresses two vulnerabilities in the python-tornado library: a denial of service via excessive URL-encoded body fields (CVE-2026-82397) and an HTTP request smuggling vulnerability via Transfer-Encoding in versions before 6.4.1 (CVE-2024-14029). The advisory rates the impact as Important and provides updated package versions for Red Hat Enterprise Linux 8.4 High Availability. Users are advised to apply the provided update to mitigate these issues.
References
- access.redhat.com/errata/RHSA-2026:84843 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2526562 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2533918 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2026/rhsa-2026_84843.json (opens in a new tab)