Skip to main content
CVE-2024-52804VulnerabilityPublished Updated

Red Hat Security Advisory: pcs security update

Affects Red Hat pcsSource GCVE Database

0
Compare
Authoritative record:CVE-2024-52804· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat tornado to 6.4.2 soon.

Data as of 5 Nov 2026, 17:04 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 3.17.5
Patch
Available – fixed in 6.4.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade tornado to 6.4.2.

Affected software

ProductAffectedFixed in
PyPItornadopkg:pypi/tornadoOther threatsAffected
  • <6.4.2
Fixed in
  • 6.4.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated pcs packages that address this vulnerability. Users should apply the security update as described in the Red Hat advisory RHSA-2025:2872 and the referenced article https://access.redhat.com/articles/11258. Applying the official patch is the recommended mitigation. No additional mitigations or workarounds are specified by the vendor.

Description

A denial of service (DoS) vulnerability exists in the HTTP cookie parsing functionality of the python-tornado component used by the pcs packages, which provide command-line configuration for Pacemaker and Corosync utilities in Red Hat Enterprise Linux 8. This issue is tracked as CVE-2024-52804. Red Hat has released an important security update addressing this vulnerability in pcs packages for multiple architectures and variants of Red Hat Enterprise Linux 8.

References

Community reviews

Loading reviews…