Skip to main content
CVE-2026-88815VulnerabilityPublished Updated

Red Hat Security Advisory: perl-DBI security update

Affects Red Hat perl-DBISource GCVE Database

0
Authoritative record:CVE-2026-88815· Medium 6.2

Not known to be exploited · CVSS 6.2 Medium : upgrade the Red Hat redhat/perl-DBI package to 1.641-4.el8_10 when convenient.

Data as of 26 Oct 2026, 12:55 UTC

CVSS 3.1 base score
6.2Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 10% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.641-4.el8_10
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/perl-DBI package to 1.641-4.el8_10.

Affected software

ProductAffectedFixed in
Red Hatredhat/perl-DBIpkg:rpm/redhat/perl-DBIOther threatsAffected
  • >=1.641 <1.641-4.el8_10
Fixed in
  • 1.641-4.el8_10
Ubuntu Pro 14.04 LTSlibdbi-perlpkg:deb/ubuntu/libdbi-perl?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 1.627-1 – 1.630-1ubuntu0.1~esm9
9 affected builds
Fixed in–
Ubuntu Pro 16.04 LTSlibdbi-perlpkg:deb/ubuntu/libdbi-perl?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • 1.633-1 – 1.634-1ubuntu0.2+esm5
9 affected builds
Fixed in–
Ubuntu Pro 18.04 LTSlibdbi-perlpkg:deb/ubuntu/libdbi-perl?arch=source&distro=esm-infra/bionicOther threatsAffected
  • 1.637-1 – 1.640-1ubuntu0.3+esm4
9 affected builds
Fixed in–
Ubuntu Pro 20.04 LTSlibdbi-perlpkg:deb/ubuntu/libdbi-perl?arch=source&distro=esm-infra/focalOther threatsAffected
  • 1.642-1 – 1.643-1ubuntu0.1+esm4
7 affected builds
Fixed in–
Ubuntu 22.04 LTSlibdbi-perlpkg:deb/ubuntu/libdbi-perl?arch=source&distro=jammyOther threatsAffected
  • 1.643-3build2 – 1.643-3ubuntu0.4
5 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

The perl-DBI package provides the standard database interface module for the Perl programming language. It implements a database-independent interface, meaning it defines a consistent set of methods, variables, and conventions for database operations. Security Fix(es): * perl-DBI: perl-DBI: Denial of Service via invalid memory read during numeric type casting (CVE-2026-88815) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…