Skip to main content
CVE-2024-10224VulnerabilityPublished Updated

Red Hat Security Advisory: perl-Module-ScanDeps security update

Affects Red Hat perl-Module-ScanDepsSource GCVE Database

0

Not known to be exploited : upgrade the Red Hat redhat/perl-Module-ScanDeps package to 9.6 when convenient.

Data as of 26 Oct 2026, 10:12 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
8.9% chance of exploitation in 30 days – higher than 95% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/perl-Module-ScanDeps package to 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/perl-Module-ScanDepspkg:rpm/redhat/perl-Module-ScanDepsOther threatsAffected
  • <9.6
  • >=9.6
  • <=9.8
Fixed in
  • 9.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update that addresses this vulnerability. Users should apply the update as described in the Red Hat advisory RHSA-2025:7350 and the linked article https://access.redhat.com/articles/11258. Applying this update mitigates the local privilege escalation risk. No additional mitigation steps are specified or required beyond applying the official patch.

Description

A local privilege escalation vulnerability (CVE-2024-10224) exists in the perl-Module-ScanDeps module used in Red Hat Enterprise Linux 9. This vulnerability arises from unsanitized input handling, allowing a local attacker to escalate privileges. Red Hat has issued a security update to address this issue in the perl-Module-ScanDeps package. The update is rated as having a moderate security impact. The advisory applies to multiple architectures and variants of Red Hat CodeReady Linux Builder for version 9 and its Extended Update Support versions 9.6 and 9.8.

References

Community reviews

Loading reviews…