Skip to main content
CVE-2025-14178VulnerabilityPublished Updated

Red Hat Security Advisory: php security update

Affects Red Hat phpSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-14178· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in Red Hat package updates : update Red Hat php when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.5.1, 8.4.16, 8.3.29 +7
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Dec 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Phpphp/phppkg:deb/php/phpOther threatsAffected
  • <8.1.34
  • <8.2.30
  • <8.3.29
  • <8.4.16
  • <8.5.1
Fixed in
  • 8.1.34
  • 8.2.30
  • 8.3.29
  • 8.4.16
  • 8.5.1
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • >=8.1.0 <8.2.0
  • >=8.2.0 <8.3.0
  • >=8.3.0 <8.4.0
  • >=8.4.0 <8.5.0
  • >=8.5.0 <8.6.0
Fixed in
  • 8.2.0
  • 8.3.0
  • 8.4.0
  • 8.5.0
  • 8.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated PHP packages for Red Hat Enterprise Linux 10.0 Extended Update Support that address these vulnerabilities. Users should apply these official updates promptly following Red Hat's guidance at https://access.redhat.com/articles/11258. Since this is an official fix, applying the update fully mitigates the vulnerabilities. No additional mitigation steps are indicated in the advisory.

Description

PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fix(es): * php: heap-based buffer overflow in array_merge() (CVE-2025-14178) * php: PHP: Denial of Service via invalid character sequence in PDO PostgreSQL prepared statement (CVE-2025-14180) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…