Skip to main content
CVE-2024-2756VulnerabilityPublished Updated

Red Hat Security Advisory: php:8.1 security update

Affects Red Hat php:8.1Source GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-2756· Medium 6.5

Not known to be exploited · CVSS 6.5 Medium · fixed in Debian package updates : update the Debian debian/php package when convenient.

Data as of 5 Nov 2026, 14:18 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (php)CVSS 3.16.5
Patch
Available – fixed in 8.4.0, 8.3.0, 8.2.0 +1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Apr 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade the Debian debian/php package to 8.4.0, 8.3.0, 8.2.0 or 8.1.0.

Affected software

ProductAffectedFixed in
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • <8.1.0
  • <8.2.0
  • <8.3.0
  • <8.4.0
Fixed in
  • 8.1.0
  • 8.2.0
  • 8.3.0
  • 8.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the PHP 8.1 module in Red Hat Enterprise Linux 9 that addresses these vulnerabilities. Users should apply the update as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the issues. No additional mitigation steps are indicated beyond applying the official update.

Description

Red Hat has issued a security advisory for PHP 8.1 on Red Hat Enterprise Linux 9, addressing multiple vulnerabilities including cookie bypass, erroneous password verification, filter bypass, multipart form data parsing errors, CGI configuration bypass, and PHP-FPM log manipulation. These issues collectively pose risks such as account takeover and security bypasses. The update is rated as having a moderate security impact. Detailed CVE references are provided for each vulnerability. Users of affected Red Hat Enterprise Linux 9 variants are advised to apply the update.

References

Community reviews

Loading reviews…