Skip to main content
CVE-2025-1220VulnerabilityPublished Updated

Red Hat Security Advisory: php:8.2 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-1220· Low 3.7

Not known to be exploited · CVSS 3.7 Low · fixed in Red Hat package updates : update the Debian debian/php package when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS base score
3.7Low
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.4.10, 8.3.23, 8.2.29 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Jul 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Debian debian/php package to 8.4.10, 8.3.23, 8.2.29 or 8.1.33.

Affected software

ProductAffectedFixed in
Debiandebian/phppkg:deb/debian/phpOther threatsAffected
  • =8.1.0
  • <8.1.33
  • =8.2.0
  • <8.2.29
  • =8.3.0
  • <8.3.23
  • =8.4.0
  • <8.4.10
Fixed in
  • 8.1.33
  • 8.2.29
  • 8.3.23
  • 8.4.10

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated PHP 8.2 packages for Red Hat Enterprise Linux 9 that address these vulnerabilities. Users should apply the security update as detailed in the Red Hat advisory RHSA-2026:1409 and the referenced article https://access.redhat.com/articles/11258. Applying the official update is the recommended and effective mitigation. No additional vendor advisories indicate that no action is required or that these issues are already mitigated without patching.

Description

PHP is an HTML-embedded scripting language commonly used with the Apache HTTP Server. Security Fix(es): * php: pgsql extension does not check for errors during escaping (CVE-2025-1735) * php: NULL Pointer Dereference in PHP SOAP Extension via Large XML Namespace Prefix (CVE-2025-6491) * php: PHP Hostname Null Character Vulnerability (CVE-2025-1220) * php: heap-based buffer overflow in array_merge() (CVE-2025-14178) * php: PHP: Information disclosure via getimagesize() function when reading multi-chunk images (CVE-2025-14177) * php: PHP: Denial of Service via invalid character sequence in PDO PostgreSQL prepared statement (CVE-2025-14180) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

References

Community reviews

Loading reviews…