Red Hat Security Advisory: php:8.3 security update
Affects Red Hat php:8.3Source GCVE Database
Not known to be exploited · CVSS 9.2 Critical : upgrade Red Hat php to 8.4.5 or 8.3.19 as a priority.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 1.4% chance of exploitation in 30 days – higher than 73% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 8.4.5, 8.3.19
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/U:AmberExploitation evidence
Disclosed: evidence found.
CVE published 4 Apr 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade php/php to 8.4.5 or 8.3.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Phpphp/phppkg:deb/php/phpOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied immediately. Red Hat has issued official patches for PHP versions 8.3 and 8.4 addressing this vulnerability. Users should upgrade to PHP 8.3.19 or later and PHP 8.4.5 or later as provided by their vendor. No additional mitigations are specified by the vendor advisory.
Description
A use-after-free vulnerability exists in PHP versions 8.3 prior to 8.3.19 and 8.4 prior to 8.4.5. The flaw involves reference counting during php_request_shutdown and can be triggered by specific code sequences using the __set handler or the ??= operator combined with exceptions. Exploitation requires control over memory layout and may allow remote code execution. Red Hat has issued security updates addressing this vulnerability.
References
- access.redhat.com/errata/RHSA-2025:7418 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2355917 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2356041 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2356042 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2356043 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2356046 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2357531 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_7418.json (opens in a new tab)
- github.com/php/php-src/security/advisories/GHSA-rwp7-7vc6-8477 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-11235 (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_7418.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-June/001543.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-11235/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-1217/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-1219/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-1734/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-1736/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-1861/ (opens in a new tab)