Skip to main content
CVE-2024-38286VulnerabilityPublished Updated

Red Hat Security Advisory: pki-servlet-engine security update

Affects Red Hat pki-servlet-engineSource GCVE Database

0
Compare
Authoritative record:CVE-2024-38286· High 8.6

Not known to be exploited · CVSS 8.6 High.

Data as of 5 Nov 2026, 17:19 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 3.18.6
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Mavenorg.apache.tomcat/tomcatpkg:maven/org.apache.tomcat/tomcatOther threatsAffected
  • 7.0.92 – 11.0.0-M20
  • <=10.1.24
  • <=9.0.89
  • <=8.5.100
  • <=7.0.109
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for the pki-servlet-engine package in Red Hat Enterprise Linux 9.0 Extended Update Support. Users should apply the update pki-servlet-engine-9.0.43-4.el9_0.1 or later as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate this vulnerability. No additional mitigation steps are indicated or required beyond applying the official patch.

Description

A denial of service vulnerability (CVE-2024-38286) has been identified in the Tomcat servlet engine component used in Red Hat Enterprise Linux 9.0 Extended Update Support. This vulnerability affects the pki-servlet-engine package and has been rated as having an important security impact by Red Hat. An update addressing this issue is available for affected Red Hat Enterprise Linux 9.0 variants.

References

Community reviews

Loading reviews…