SUSE · security update for podman
Affects SUSESource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.7 Medium : upgrade to 5.2.4 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 21% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.2.4, 1.37.4
Exploitation evidence
Disclosed: evidence found.
CVE published 1 Oct 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade podman to 5.2.4; buildah to 1.37.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| podman | Affected
| Fixed in
|
| buildah | Affected
| Fixed in
|
| Red HatRed Hat Enterprise Linux 8 | Affected– | Fixed in– |
| Red HatRed Hat Enterprise Linux 9 | Affected– | Fixed in– |
| Red HatRed Hat Enterprise Linux 9 | Affected– | Fixed in– |
| Red HatRed Hat Enterprise Linux 9 | Affected– | Fixed in– |
| Red HatRed Hat Enterprise Linux 9.4 Extended Update Support | Affected– | Fixed in– |
| Red HatRed Hat OpenShift Container Platform 4.16 | Affected– | Fixed in– |
| Red HatRed Hat Enterprise Linux 10 | Affected– | Fixed in– |
| Red HatRed Hat OpenShift Container Platform 4 | Affected– | Fixed in– |
| Red HatRed Hat OpenShift Container Platform 4 | Affected– | Fixed in– |
GitHubpodmanpkg:github/podmanOther threats | Affected
| Fixed in
|
GitHubbuildahpkg:github/buildahOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Red Hat has released updated packages for podman and related components that address these vulnerabilities. Users running affected versions of Red Hat Enterprise Linux 9 (>=9.0.0 <9.9.0) should apply the security updates as described in the Red Hat advisory RHSA-2024:9051 and the referenced article https://access.redhat.com/articles/11258. No additional mitigation steps are indicated beyond applying the official patches.
Description
The podman tool manages pods, container images, and containers. It is part of the libpod library, which is for applications that use container pods. Container pods is a concept in Kubernetes. Security Fix(es): * Buildah: Podman: Improper Input Validation in bind-propagation Option of Dockerfile RUN --mount Instruction (CVE-2024-9407) * buildah: Buildah allows arbitrary directory mount (CVE-2024-9675) * Podman: Buildah: CRI-O: symlink traversal vulnerability in the containers/storage library can cause Denial of Service (DoS) (CVE-2024-9676) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.
References
- access.redhat.com/errata/RHSA-2024:9051 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2315887 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2317458 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2317467 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_9051.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_9051.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2024-November/000213.html (opens in a new tab)
- suse.com/security/cve/CVE-2024-9407/ (opens in a new tab)
- suse.com/security/cve/CVE-2024-9675/ (opens in a new tab)
- suse.com/security/cve/CVE-2024-9676/ (opens in a new tab)