Skip to main content
CVE-2026-42198VulnerabilityPublished Updated

Red Hat Security Advisory: postgresql-jdbc security update

Affects Red Hat postgresql-jdbcSource GCVE Database

0
Compare

Not known to be exploited · fixed in Red Hat package updates : patch Red Hat postgresql-jdbc soon.

Data as of 6 Nov 2026, 02:02 UTC

Severity
High

Rated by Threat Radar · CVSS not yet scored by NVD

Patch
Available – fixed in 42.2.28

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

AI-suggested

Red Hat has provided an official security update that fixes this vulnerability. Users of affected Red Hat Enterprise Linux 9.4 Update Services for SAP Solutions should apply the postgresql-jdbc package update to version 42.2.28-1.el9_4.1 or later as detailed in Red Hat advisory RHSA-2026:52929. No additional mitigation steps are required beyond applying this update.

Description

A security vulnerability (CVE-2026-42198) affects the postgresql-jdbc package used by Java programs to access PostgreSQL databases. The flaw allows a client-side denial of service via malicious SCRAM-SHA-256 authentication. Red Hat has issued an important security update for this vulnerability in their Enterprise Linux 9.4 Update Services for SAP Solutions. The update addresses the issue by patching the postgresql-jdbc package to prevent exploitation.

References

Community reviews

Loading reviews…