SUSE · security update for postgresql
Affects SUSESource GCVE Database
Not known to be exploited · fixed in 16.4.0 : patch SUSE soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 16.4.0, 15.8.0, 14.13.0 +2
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Aug 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/postgresqlpkg:rpm/redhat/postgresqlOther threats | Affected
| Fixed in– |
Bitnamipostgresqlpkg:bitnami/postgresqlOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied promptly. Refer to vendor advisories such as Red Hat's RHSA-2024:8495 and SUSE's security updates for detailed patch instructions. Applying the official fixes eliminates the vulnerability. No additional mitigations are indicated by the vendor advisories.
Description
A Time-of-check Time-of-use (TOCTOU) race condition vulnerability exists in the pg_dump utility of PostgreSQL. This flaw allows an object creator to execute arbitrary SQL functions with the privileges of the user running pg_dump, which is often a superuser. The attack involves replacing a relation type with a view or foreign table during the dump process. Versions prior to PostgreSQL 16.4, 15.8, 14.13, 13.16, and 12.20 are affected. A patch is available to address this issue.
References
- access.redhat.com/errata/RHSA-2024:8495 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2024/rhsa-2024_8495.json (opens in a new tab)
- postgresql.org/support/security/CVE-2024-7348/ (opens in a new tab)
- openwall.com/lists/oss-security/2024/08/11/1 (opens in a new tab)
- security.netapp.com/advisory/ntap-20240822-0002/ (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2024-7348 (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2024_5999.json (opens in a new tab)
- suse.com/security/cve/CVE-2024-7348/ (opens in a new tab)