Skip to main content
CVE-2024-10979VulnerabilityPublished Updated

CVE-2024-10979: PostgreSQL · External Control of System or Configuration Setting

Affects PostgreSQLSource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 17.1 : patch PostgreSQL soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.3% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 17.1, 16.5, 15.9 +3
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Postgresqlpostgresql/postgresqlpkg:deb/postgresql/postgresqlOther threatsAffected
  • <17.1
  • <16.5
  • <15.9
  • <14.14
  • <13.17
  • <12.21
Fixed in
  • 17.1
  • 16.5
  • 15.9
  • 14.14
  • 13.17
  • 12.21

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Immediately upgrade PostgreSQL installations to the fixed versions: 17.1, 16.5, 15.9, 14.14, 13.17, or 12.21 as applicable. 2. If upgrading is not immediately possible, disable or restrict the use of PL/Perl procedural language to trusted database roles only, minimizing exposure. 3. Implement strict access controls and auditing on database users who have permission to execute PL/Perl functions. 4. Monitor environment variables and process execution contexts on database servers for unauthorized changes, using host-based intrusion detection systems. 5. Employ network segmentation and least privilege principles to limit the impact of potential exploitation. 6. Review and harden operating system and database server configurations to reduce the attack surface, including disabling unnecessary procedural languages if not in use. 7. Stay informed on PostgreSQL security advisories and apply patches promptly. 8. Conduct regular security assessments and penetration testing focusing on procedural language extensions and environment variable handling.

Description

Incorrect control of environment variables in PostgreSQL PL/Perl allows an unprivileged database user to change sensitive process environment variables (e.g. PATH). That often suffices to enable arbitrary code execution, even if the attacker lacks a database server operating system user. Versions before PostgreSQL 17.1, 16.5, 15.9, 14.14, 13.17, and 12.21 are affected.

References

Community reviews

Loading reviews…