Skip to main content
CVE-2025-8714VulnerabilityPublished Updated

Red Hat Security Advisory: postgresql:12 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2025-8714· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 8.7 soon.

Data as of 26 Oct 2026, 06:26 UTC

CVSS base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 55% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.7

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Red Hat to 8.7.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=8.6 <8.7
Fixed in
  • 8.7

AI-suggested

Red Hat has released official security updates for PostgreSQL 12 on Red Hat Enterprise Linux 8.6 and related variants. Users should apply these updates as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the vulnerabilities. No additional mitigation steps are indicated beyond applying the official patches.

Description

Red Hat has issued a security update for PostgreSQL 12 addressing multiple vulnerabilities that allow arbitrary code execution during restore operations and via untrusted data inclusion in pg_dump. These vulnerabilities could enable an attacker to execute code on affected systems. The update is rated as important by Red Hat Product Security. The advisory applies to Red Hat Enterprise Linux 8.6 and related variants. Users are advised to apply the provided updates to mitigate these issues.

References

Community reviews

Loading reviews…