Skip to main content
CVE-2026-96640VulnerabilityPublished

Red Hat Security Advisory: python-pillow security update

Affects Red Hat python-pillowSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-96640· High 8.2

Not known to be exploited · CVSS 8.2 High : upgrade Red Hat pillow to 13.0.0 soon.

Data as of 30 Oct 2026, 02:18 UTC

CVSS 4.0 base score
8.2High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.2
Patch
Available – fixed in 13.0.0
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade Pillow to 13.0.0.

Affected software

ProductAffectedFixed in
python-pillowPillowAffected
  • >=5.1.0 <13.0.0
Fixed in
  • 13.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated python-pillow packages that address these denial of service vulnerabilities. Users should apply the security update available for Red Hat Enterprise Linux 8 and related products as described in the Red Hat advisory RHSA-2026:92639. No additional mitigations are specified beyond applying the official update.

Description

Multiple denial of service vulnerabilities have been identified in the python-pillow library used in Red Hat Enterprise Linux 8. These issues include unbounded recursion, double free, null pointer dereference, infinite loops, out-of-bounds memory access, and unbounded memory expansion triggered by crafted image or PDF files. The vulnerabilities could cause application crashes or resource exhaustion when processing maliciously crafted images or PDFs.

References

Community reviews

Loading reviews…