Skip to main content
VulnerabilityPublished Updated

CVE-2024-47081: Parsedmarc · Requests vulnerable to .netrc credentials leak via malicious URLs

Affects parsedmarcSource GCVE Database

0
Authoritative record:CVE-2024-47081· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 8.18.5_1 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.9% chance of exploitation in 30 days – higher than 61% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.37.10_1, 1.1.15_6, 4.5.0_1 +2
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 9 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Homebrewlocustpkg:brew/locustOther threatsAffected
  • >=2.2.1 <2.37.10_1
Fixed in
  • 2.37.10_1
Homebrewonlykey-agentpkg:brew/onlykey-agentOther threatsAffected
  • >=1.1.14 <1.1.15_6
Fixed in
  • 1.1.15_6
Homebrewlocalstackpkg:brew/localstackOther threatsAffected
  • >=0.11.3.3 <4.5.0_1
Fixed in
  • 4.5.0_1
PyPIrequestsAffected
  • <2.32.4
Fixed in
  • 2.32.4
Homebrewparsedmarcpkg:brew/parsedmarcOther threatsAffected
  • >=8.11.0 <8.18.5_1
Fixed in
  • 8.18.5_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an official security update for python-requests (version 2.25.1-10.el9_6) that addresses CVE-2024-47081. Users of affected Red Hat Enterprise Linux 9 variants should apply the update promptly by following Red Hat's update instructions at https://access.redhat.com/articles/11258. No additional mitigation steps are indicated by the vendor advisory.

Description

### Impact Due to a URL parsing issue, Requests releases prior to 2.32.4 may leak .netrc credentials to third parties for specific maliciously-crafted URLs. ### Workarounds For older versions of Requests, use of the .netrc file can be disabled with `trust_env=False` on your Requests Session ([docs](https://requests.readthedocs.io/en/latest/api/#requests.Session.trust_env)). ### References https://github.com/psf/requests/pull/6965 https://seclists.org/fulldisclosure/2025/Jun/2

References

Community reviews

Loading reviews…