Skip to main content
CVE-2025-47287VulnerabilityPublished Updated

CVE-2025-47287: Python tornado · When Tornado's multipart/form-data parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data

Affects python-tornadoSource GCVE Database

0

Not known to be exploited · CVSS 7.5 Medium : upgrade to 6.1.0-3ubuntu0.1~esm2 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
7.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.2.2_2, 2.17_1, 6.1.0-3ubuntu0.1~esm2 +2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 May 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Homebrewsnakevizpkg:brew/snakevizOther threatsAffected
  • >=2.2.0 <2.2.2_2
Fixed in
  • 2.2.2_2
Homebrewnvcheckerpkg:brew/nvcheckerOther threatsAffected
  • >=2.7 <2.17_1
Fixed in
  • 2.17_1
Ubuntu:Pro:16.04:LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-infra-legacy/xenialOther threatsAffected
  • =4.2.1-1ubuntu2
  • =4.2.1-1ubuntu3
  • =4.2.1-1ubuntu3.1
  • =4.2.1-1ubuntu3.1+esm1
  • =4.2.1-1ubuntu3.1+esm2
  • =4.2.1-1ubuntu3.1+esm3
  • =4.2.1-1ubuntu3.1+esm4
Fixed in–
Ubuntu:Pro:18.04:LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/bionicOther threatsAffected
  • =4.5.1-2.1~build2
  • =4.5.2-1
  • =4.5.3-1
  • =4.5.3-1ubuntu0.1
  • =4.5.3-1ubuntu0.2
  • =4.5.3-1ubuntu0.2+esm1
  • =4.5.3-1ubuntu0.2+esm2
  • =4.5.3-1ubuntu0.2+esm3
  • =4.5.3-1ubuntu0.2+esm4
Fixed in–
Ubuntu:Pro:20.04:LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/focalOther threatsAffected
  • =5.1.1-4ubuntu1
  • =5.1.1-4ubuntu5
  • =6.0.3+really5.1.1-2
  • =6.0.3+really5.1.1-2build1
  • =6.0.3+really5.1.1-2build2
  • =6.0.3+really5.1.1-3
  • =6.0.3+really5.1.1-3ubuntu0.1~esm1
  • =6.0.3+really5.1.1-3ubuntu0.1~esm3
  • =6.0.3+really5.1.1-3ubuntu0.1~esm5
  • =6.0.3+really5.1.1-3ubuntu0.1~esm7
Fixed in–
Ubuntu:Pro:22.04:LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=esm-apps/jammyOther threatsAffected
  • <6.1.0-3ubuntu0.1~esm2
  • =6.1.0-1build1
  • =6.1.0-2
  • =6.1.0-3
  • =6.1.0-3build1
  • =6.1.0-3ubuntu0.1~esm1
Fixed in
  • 6.1.0-3ubuntu0.1~esm2
Ubuntu:24.04:LTSpython-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=nobleOther threatsAffected
  • <6.4.0-1ubuntu0.2
  • =6.3.2-1
  • =6.4.0-0ubuntu1
  • =6.4.0-1
  • =6.4.0-1build1
  • =6.4.0-1ubuntu0.1
Fixed in
  • 6.4.0-1ubuntu0.2
Ubuntu:25.10python-tornadopkg:deb/ubuntu/python-tornado?arch=source&distro=questingOther threatsAffected
  • <6.4.2-2
  • =6.4.2-1
Fixed in
  • 6.4.2-2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an updated python-tornado package version 6.4.2-1.el10_0.1 that addresses this vulnerability. Users should apply the update as described in Red Hat advisory RHSA-2025:8135 and the referenced article https://access.redhat.com/articles/11258 to remediate this issue. No other mitigation steps are indicated by the vendor.

Description

### Summary When Tornado's ``multipart/form-data`` parser encounters certain errors, it logs a warning but continues trying to parse the remainder of the data. This allows remote attackers to generate an extremely high volume of logs, constituting a DoS attack. This DoS is compounded by the fact that the logging subsystem is synchronous. ### Affected versions All versions of Tornado prior to 6.5 are affected. The vulnerable parser is enabled by default. ### Solution Upgrade to Tornado version 6.5. In the meantime, risk can be mitigated by blocking `Content-Type: multipart/form-data` in a proxy.

References

Community reviews

Loading reviews…