Skip to main content
CVE-2024-0397VulnerabilityPublished Updated

SUSE · security update for python3.11

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-0397· High 7.4

Not known to be exploited · CVSS 7.4 High : upgrade the Red Hat redhat/python3.11 package to 9.5.0 soon.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 3.1 base score
7.4High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 56% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jun 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/python3.11 package to 9.5.0.

Affected software

ProductAffectedFixed in
Red Hatredhat/python3.11pkg:rpm/redhat/python3.11Other threatsAffected
  • <9.5.0
Fixed in
  • 9.5.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for python3.11 is available from Red Hat and should be applied to affected systems. The vendor advisory (RHSA-2024:9192) provides detailed instructions for patching. Applying this update mitigates the zip-bomb and malicious ZIP iteration denial of service vulnerabilities. No additional action is required beyond installing the official patch.

Description

A security update for python3.11 addresses vulnerabilities in the zipfile module that could lead to denial of service conditions. Specifically, CVE-2024-0450 involves zip-bomb vulnerabilities, and CVE-2024-8088 concerns denial of service caused by iterating over malicious ZIP files. These issues affect Red Hat Enterprise Linux 9 and related distributions. The update is rated as having moderate security impact and a patch is available.

References

Community reviews

Loading reviews…