Skip to main content
CVE-2024-26130VulnerabilityPublished Updated

SUSE · security update for python3.12-cryptography

Affects SUSESource GCVE Database

0

Not known to be exploited : upgrade to 50.0.0 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 50.0.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 10 Sep 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade cryptography to 50.0.0.

Affected software

ProductAffectedFixed in
Homebrewcryptographypkg:brew/cryptographyOther threatsAffected
  • <50.0.0
Fixed in
  • 50.0.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available and has been released by Red Hat for python3.12-cryptography packages. Users should apply the official patches provided by their vendor to remediate this vulnerability. Refer to Red Hat advisory RHSA-2025:15608 for update instructions. No additional mitigation is required beyond applying the vendor-provided fix.

Description

A NULL pointer dereference vulnerability (CVE-2024-26130) exists in the python-cryptography library's pkcs12.serialize_key_and_certificates function when called with a non-matching certificate and private key along with an hmac_hash override. This flaw can cause a denial of service by crashing applications using the library. The issue affects cryptography versions prior to 50.0.0. Red Hat has released security updates for their python3.12-cryptography packages to address this vulnerability.

References

Community reviews

Loading reviews…