Skip to main content
CVE-2025-8291VulnerabilityPublished Updated

SUSE · security update for python3.12

Affects SUSESource GCVE Database

0
Authoritative record:CVE-2025-8291· Medium 4.3

Not known to be exploited · CVSS 4.3 Medium : upgrade SUSE to 3.12.9 when convenient.

Data as of 26 Oct 2026, 09:16 UTC

CVSS 3.1 base score
4.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.12.9
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade SUSE to 3.12.9.

Affected software

ProductAffectedFixed in
SUSE Product Security Team SUSEAffected
  • >=3.12.0 <3.12.9
  • SUSE
  • i686
  • python3.12-0:3.12.9-1.el9_6.3.i686
  • python3.12-debug-0:3.12.9-1.el9_6.3.i686
  • python3.12-devel-0:3.12.9-1.el9_6.3.i686
Fixed in
  • 3.12.9

AI-suggested

Red Hat has released an official security update rebasing python3.12 to version 3.12.12 that fixes this vulnerability. Users running affected versions of Red Hat Enterprise Linux 9 and related variants should apply the update as described in Red Hat advisory RHSA-2025:23323. No additional mitigation steps are indicated by the vendor.

Description

A moderate severity security vulnerability (CVE-2025-8291) affects Python 3.12 in Red Hat Enterprise Linux 9.6 Extended Update Support and related products. The issue involves the Python zipfile module where the End of Central Directory (EOCD) Locator record offset is not properly checked. This vulnerability has been addressed by Red Hat in updated python3.12 packages. Users of affected Red Hat Enterprise Linux 9.6 EUS and CodeReady Linux Builder 9.6 should apply the provided security update to remediate the issue.

References

Community reviews

Loading reviews…