Skip to main content
CVE-2024-9287VulnerabilityPublished Updated

Red Hat Security Advisory: python3.12 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 3.12.8 soon.

Data as of 25 Oct 2026, 19:02 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.12.8

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade Red Hat to 3.12.8.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=3.12.0 <3.12.8
Fixed in
  • 3.12.8

AI-suggested

Red Hat has released updated python3.12 packages for Red Hat Enterprise Linux 8 that fix these vulnerabilities. Users should apply the python3.12 update (version 3.12.8-1.el8_10) available from Red Hat to remediate these issues. For detailed update instructions, refer to the Red Hat article at https://access.redhat.com/articles/11258. No additional mitigations are indicated by the vendor advisory.

Description

Red Hat has issued a security advisory for python3.12 addressing two vulnerabilities: CVE-2024-9287, where virtual environment activation scripts do not quote paths, and CVE-2024-12254, involving unbounded memory buffering in SelectorSocketTransport.writelines(). These issues affect Red Hat Enterprise Linux 8 and related variants. The advisory rates the update as important and provides updated packages to remediate these vulnerabilities.

References

Community reviews

Loading reviews…