Skip to main content
CVE-2024-9287VulnerabilityPublished Updated

Red Hat Security Advisory: python3.12 security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 9.5 soon.

Data as of 26 Oct 2026, 06:26 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.5

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade Red Hat to 9.5.

Affected software

ProductAffectedFixed in
Red Hat Product Security Red HatAffected
  • >=9.4 <9.5
Fixed in
  • 9.5

AI-suggested

Red Hat has released updated python3.12 packages for Red Hat Enterprise Linux 9.4 Extended Update Support and related variants that fix these vulnerabilities. Users should apply these official updates as soon as possible. For detailed update instructions, refer to the Red Hat advisory at https://access.redhat.com/articles/11258. No additional mitigations are specified or required beyond applying the official patches.

Description

Red Hat has issued a security advisory for python3.12 addressing two vulnerabilities: CVE-2024-9287, where virtual environment activation scripts do not quote paths, and CVE-2024-12254, involving unbounded memory buffering in SelectorSocketTransport.writelines(). These issues affect Red Hat Enterprise Linux 9.4 Extended Update Support and related variants. The advisory rates the update as important and provides updated packages to remediate the vulnerabilities.

References

Community reviews

Loading reviews…