Skip to main content
CVE-2025-11234VulnerabilityPublished Updated

Red Hat Security Advisory: qemu-kvm security update

Affects Red Hat qemu-kvmSource GCVE Database

0
Compare
Authoritative record:CVE-2025-11234· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade Red Hat qemu-kvm to 10.1.2 soon.

Data as of 5 Nov 2026, 16:03 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.5
Patch
Available – fixed in 10.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade qemu to 10.1.2.

Affected software

ProductAffectedFixed in
qemuAffected
  • >=2.6.0 <10.1.2
Fixed in
  • 10.1.2

AI-suggested

Red Hat has released updated qemu-kvm packages for Red Hat Enterprise Linux 9.2 and its variants that address CVE-2025-11234. Users should apply these official security updates as described in Red Hat's advisory and article (https://access.redhat.com/articles/11258) to remediate the vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A use-after-free vulnerability exists in the VNC WebSocket handshake implementation of qemu-kvm, a user-space component for running virtual machines with Kernel-based Virtual Machine (KVM) on Linux. This vulnerability is identified as CVE-2025-11234 and has been rated with moderate security impact by Red Hat. The issue affects Red Hat Enterprise Linux 9.2 Update Services for SAP Solutions and related variants. A security update addressing this vulnerability is available from Red Hat.

References

Community reviews

Loading reviews…