Skip to main content
CVE-2025-3158VulnerabilityPublished Updated

SUSE · security update for qt5-qt3d

Affects SUSESource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade the Red Hat redhat/qt5-qt3d package to 9.8 or 9.6 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

Severity
Medium

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.3% chance of exploitation in 30 days – higher than 25% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 9.8, 9.6

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Aug 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Red Hat redhat/qt5-qt3d package to 9.8 or 9.6.

Affected software

ProductAffectedFixed in
Red Hatredhat/qt5-qt3dpkg:rpm/redhat/qt5-qt3dOther threatsAffected
  • =9
  • <9.6
  • >=9.6 <9.8
Fixed in
  • 9.6
  • 9.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update for qt5-qt3d is available from Red Hat and should be applied to affected systems. The update addresses the heap-based buffer overflow vulnerabilities in the assimp library components. Refer to the Red Hat advisory RHSA-2025:12842 and the linked article https://access.redhat.com/articles/11258 for detailed instructions on applying the update. No additional mitigation steps are required beyond applying the official patch.

Description

Two heap-based buffer overflow vulnerabilities were identified in the Open Asset Import Library (assimp) components used by Qt 3D, specifically in LWOAnimation.cpp and ASEParser.cpp. These vulnerabilities affect the qt5-qt3d package in Red Hat Enterprise Linux 9 and related distributions. The issues have been assigned CVE identifiers CVE-2025-3158 and CVE-2025-3159. Red Hat has released security updates addressing these vulnerabilities.

References

Community reviews

Loading reviews…