Skip to main content
CVE-2024-39936VulnerabilityPublished Updated

Red Hat Security Advisory: qt5-qtbase security update

Affects Red Hat qt5-qtbaseSource GCVE Database

0
Compare
Authoritative record:CVE-2024-39936· High 8.6

Not known to be exploited · CVSS 8.6 High · fixed in Red Hat package updates : patch Red Hat qtbase soon.

Data as of 5 Nov 2026, 17:05 UTC

CVSS 3.1 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 6.7.3, 6.5.7, 6.2.13 +1
CVSS:3.1/AC:L/AV:N/A:N/C:H/I:N/PR:N/S:C/UI:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade org.qtproject/qtbase to 6.7.3, 6.5.7, 6.2.13 or 5.15.18.

Affected software

ProductAffectedFixed in
Mavenorg.qtproject/qtbasepkg:maven/org.qtproject/qtbaseOther threatsAffected
  • <5.15.18
  • <6.2.13
  • >=6.3 <6.5.7
  • >=6.6 <6.7.3
Fixed in
  • 5.15.18
  • 6.2.13
  • 6.5.7
  • 6.7.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an updated qt5-qtbase package for Red Hat Enterprise Linux 9.0 that includes the fix for CVE-2024-39936. Users should apply this update as detailed in the Red Hat advisory (https://access.redhat.com/articles/11258) to remediate the vulnerability. No additional mitigation steps are indicated beyond applying the official update.

Description

A security update for the qt5-qtbase package in Red Hat Enterprise Linux 9.0 addresses a vulnerability identified as CVE-2024-39936. The issue involves the Qt base tools used for string, XML, and network handling. The fix delays any communication until the encrypted() signal can be responded to, mitigating the vulnerability. This update is rated as Important by Red Hat Product Security.

References

Community reviews

Loading reviews…