Skip to main content
CVE-2026-96889VulnerabilityPublished

Red Hat Security Advisory: Red Hat AI Base Images 3.4.7 (ROCm 7.1)

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-96889· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade Red Hat librsvg to 2.63.1 soon.

Data as of 4 Nov 2026, 06:43 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.17.8
Patch
Available – fixed in 2.63.1
CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade librsvg/librsvg to 2.63.1.

Affected software

ProductAffectedFixed in
crates.iolibrsvg/librsvgpkg:cargo/librsvg/librsvgOther threatsAffected
  • <2.63.1
Fixed in
  • 2.63.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat recommends updating system Brotli/libbrotli packages for affected Node.js and .NET environments where applicable. Platform hardenings such as ASLR, NX, FORTIFY_SOURCE, and SELinux help mitigate exploitation risk. For Node.js versions using system Brotli, update the system Brotli package.

Description

CVE-2026-96889 is a security advisory related to Red Hat AI Base Images 3.4.7 (ROCm 7.1). The advisory references two CVEs, including CVE-2026-111497, which describes a high-severity out-of-bounds write vulnerability in the Google Brotli decoder. This vulnerability can be triggered by a crafted Brotli-compressed stream, potentially leading to memory disclosure, denial of service, or arbitrary code execution when decompressing untrusted Brotli data. Red Hat rates this issue as Important with high attack complexity due to required conditions for exploitation and platform hardenings. No fixes are currently available for the Red Hat AI Base Images 3.4.7, and affected versions are not explicitly stated.

References

Community reviews

Loading reviews…