Skip to main content
CVE-2024-11079VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Ansible Automation Platform Execution Environments Container Release Update

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2024-11079· Medium 5.5

Not known to be exploited · CVSS 5.5 Medium · fixed in Red Hat package updates : update Red Hat when convenient.

Data as of 26 Oct 2026, 08:30 UTC

CVSS base score
5.5Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.18, 2.17.7, 2.16.14 +1

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade ansible-core to 2.18, 2.17.7, 2.16.14 or 2.15.13.

Affected software

ProductAffectedFixed in
PyPIansible-corepkg:pypi/ansible-coreOther threatsAffected
  • <2.15.13
  • <2.16.14
  • <2.17.7
  • <2.18
Fixed in
  • 2.15.13
  • 2.16.14
  • 2.17.7
  • 2.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released official fixes for this vulnerability. Users should update ansible-core to one of the fixed versions: 2.15.13, 2.16.14, 2.17.7, or 2.18.1 within their Ansible Automation Platform Execution Environments containers. Applying these updates will remediate the unsafe tagging bypass issue. No additional mitigation steps are indicated by the vendor.

Description

A moderate severity vulnerability (CVE-2024-11079) in Red Hat Ansible Automation Platform's ansible-core component allows an unsafe tagging bypass via the hostvars object. This issue affects multiple ansible-core versions used in the Execution Environments containers. Red Hat has released updated ansible-core versions in the 2.15, 2.16, 2.17, and 2.18 streams to address this vulnerability. The advisory recommends updating to these fixed versions to mitigate the risk.

References

Community reviews

Loading reviews…