CVE-2025-43859: Uvicorn · h11 accepts some malformed Chunked-Encoding bodies
Affects uvicornSource GCVE Database
Not known to be exploited · CVSS 9.1 Critical : upgrade to 0.34.2_1 as a priority.
Data as of 25 Oct 2026, 19:02 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 48% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 0.34.2_1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade uvicorn to 0.34.2_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewuvicornpkg:brew/uvicornOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in h11 version 0.15.0 that corrects the parsing of chunked-encoding bodies. Remediation involves upgrading h11 to 0.15.0 or later. Additionally, fixing any buggy proxies that incorrectly parse chunked-encoding bodies also mitigates the issue. Since exploitation requires both components to be vulnerable, fixing either the h11 library or the proxy is sufficient to prevent exploitation.
Description
A vulnerability in the h11 HTTP library used by Uvicorn allows acceptance of malformed HTTP/1.1 chunked-encoding bodies due to lenient parsing of trailing bytes. This can cause request smuggling when combined with a proxy that parses chunked bodies differently. The issue is fixed in h11 version 0.15.0. Exploitation requires both a buggy h11 and a buggy proxy, so fixing either component mitigates the risk.
References
- access.redhat.com/errata/RHSA-2025:8615 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2362162 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_8615.json (opens in a new tab)
- access.redhat.com/errata/RHSA-2025:7536 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_7536.json (opens in a new tab)
- github.com/python-hyper/h11/security/advisories/GHSA-vqfr-h8mv-ghfj (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-43859 (opens in a new tab)
- github.com/python-hyper/h11/commit/114803a29ce50116dc47951c690ad4892b1a36ed (opens in a new tab)
- github.com/python-hyper/h11 (opens in a new tab)