Skip to main content
CVE-2025-2877VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.4 Product Security and Bug Fix Update

Affects Red HatSource GCVE Database

0

Not known to be exploited : upgrade to 2.4.8 soon.

Data as of 26 Oct 2026, 06:15 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
0.4% chance of exploitation in 30 days – higher than 36% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.8

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Apr 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade redhat/ansible-automation-platform to 2.4.8.

Affected software

ProductAffectedFixed in
Red Hatredhat/ansible-automation-platformpkg:rpm/redhat/ansible-automation-platformOther threatsAffected
  • =2.4.0
  • <2.4.8
Fixed in
  • 2.4.8

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has provided an official fix by updating ansible-rulebook to version 1.0.8 and automation-controller to version 4.5.21. Users of Red Hat Ansible Automation Platform 2.4 should apply these updates promptly to remediate the vulnerability. No additional mitigations are specified beyond applying the official patches.

Description

A security vulnerability (CVE-2025-2877) in Red Hat Ansible Automation Platform 2.4's ansible-rulebook component exposes inventory passwords in plain text when starting a rulebook activation with verbosity set to debug in Event-Driven Ansible (EDA). This issue has been addressed by updating ansible-rulebook to version 1.0.8 and automation-controller to version 4.5.21. The vulnerability is rated as high severity by Red Hat Product Security.

References

Community reviews

Loading reviews…