Skip to main content
CVE-2024-52304VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Ansible Automation Platform Execution Environments Container Release Update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Authoritative record:CVE-2024-52304· Medium 6.3

Not known to be exploited · CVSS 6.3 Medium : upgrade Red Hat to 0.19.3_1 when convenient.

Data as of 26 Oct 2026, 09:15 UTC

CVSS 4.0 base score
6.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.19.3_1
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 18 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade vdirsyncer to 0.19.3_1.

Affected software

ProductAffectedFixed in
Homebrewvdirsyncerpkg:brew/vdirsyncerOther threatsAffected
  • >=0.19.0 <0.19.3_1
Fixed in
  • 0.19.3_1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated container images for the Ansible Automation Platform Execution Environments that address these vulnerabilities. Users should apply the updates provided in Red Hat Security Advisory RHSA-2025:1101 to remediate these issues. No additional mitigation steps are indicated beyond applying the official updates.

Description

### Summary The Python parser parses newlines in chunk extensions incorrectly which can lead to request smuggling vulnerabilities under certain conditions. ### Impact If a pure Python version of aiohttp is installed (i.e. without the usual C extensions) or `AIOHTTP_NO_EXTENSIONS` is enabled, then an attacker may be able to execute a request smuggling attack to bypass certain firewalls or proxy protections. ----- Patch: https://github.com/aio-libs/aiohttp/commit/259edc369075de63e6f3a4eaade058c62af0df71

References

Community reviews

Loading reviews…