Skip to main content
CVE-2024-53907VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Ansible Automation Platform 2.4 Container Release Update

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2024-53907· High 7.5

Not known to be exploited · CVSS 7.5 High · fixed in Red Hat package updates : patch Red Hat django soon.

Data as of 3 Nov 2026, 18:13 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.1.4, 5.0.10, 4.2.17
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Dec 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade django to 5.1.4, 5.0.10 or 4.2.17.

Affected software

ProductAffectedFixed in
PyPIdjangopkg:pypi/djangoOther threatsAffected
  • <4.2.17
  • <5.0.10
  • <5.1.4
Fixed in
  • 4.2.17
  • 5.0.10
  • 5.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released updated versions of the Ansible Automation Platform 2.4 components that address these vulnerabilities. Users should apply the updates to Ansible Lightspeed (2.4.20241210), Automation Controller (4.5.15), and the ansible.controller collection (4.5.15) as soon as possible. These updates contain the necessary fixes for CVE-2024-53907 and CVE-2024-53908. No additional mitigation steps are indicated in the vendor advisory.

Description

Red Hat Ansible Automation Platform 2.4 has been updated to address two security vulnerabilities in the included Django framework. The first is a potential denial-of-service vulnerability in django.utils.html.strip_tags() (CVE-2024-53907), and the second is a potential SQL injection vulnerability in the HasKey(lhs, rhs) function on Oracle databases (CVE-2024-53908). These issues could impact the security of automation deployments using this platform. Updated component versions have been released to mitigate these risks.

References

Community reviews

Loading reviews…