Skip to main content
CVE-2026-47683VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Developer Hub 1.9.10 release

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-47683· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade Red Hat vm2 to 3.11.6 soon.

Data as of 30 Oct 2026, 02:59 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.11.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade vm2 to 3.11.6.

Affected software

ProductAffectedFixed in
patriksimekvm2Affected
  • <3.11.6
Fixed in
  • 3.11.6
npmvm2pkg:npm/vm2Other threatsAffected
  • <3.11.6
Fixed in
  • 3.11.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

No fixes are currently available for Red Hat Developer Hub 1.9.10. Network-level protections and certificate pinning may reduce risk. Red Hat does not provide a direct fix for this version at this time.

Description

Red Hat Developer Hub (RHDH) 1.9.10 is an enterprise-grade developer portal based on Backstage.io, supporting Kubernetes clusters. The advisory mentions multiple CVEs including CVE-2026-111943, which involves a flaw in Go's crypto/x509 package that improperly validates certificates, allowing man-in-the-middle attacks via untrusted intermediate certificates. No fixes are currently available for RHDH 1.9.10. The vulnerability requires specific network positioning and attacker-controlled certificates. Red Hat rates this issue as important due to the potential compromise of secure communications.

References

Community reviews

Loading reviews…