Skip to main content
CVE-2026-4599VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Quay 3.10.20

Affects Red HatSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-4599· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade Red Hat jsrsasign to 11.1.1 as a priority.

Data as of 30 Oct 2026, 11:52 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 11.1.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 23 Mar 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade jsrsasign to 11.1.1.

Affected software

ProductAffectedFixed in
jsrsasignAffected
  • >=7.0.0 <11.1.1
Fixed in
  • 11.1.1
org.webjars.npm:jsrsasignAffected
  • >=8.0.12
Fixed in–
npmjsrsasignpkg:npm/jsrsasignOther threatsAffected
  • <=11.1.1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released Quay 3.10.20 which includes bug fixes addressing these vulnerabilities. Users should apply this update after confirming that all previously released errata relevant to their system have been applied. The advisory does not explicitly confirm patch availability for all CVEs, so users should monitor Red Hat's official advisories and apply updates promptly. For the Authlib vulnerability (CVE-2026-28498), upgrading to Authlib version 1.6.9 or later mitigates the issue. No additional mitigations or workarounds are specified by Red Hat.

Description

Quay 3.10.20

References

Community reviews

Loading reviews…