Skip to main content
CVE-2024-12797VulnerabilityPublished Updated

Red Hat Security Advisory: Red Hat Service Interconnect security update

Affects Red HatSource GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited : upgrade to 2.70.0 soon.

Data as of 26 Oct 2026, 07:57 UTC

Severity
High

Rated by Threat Radar · No CVSS score from NVD or the CNA

EPSS
2.5% chance of exploitation in 30 days – higher than 84% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.70.0

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jun 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade azure-cli to 2.70.0.

Affected software

ProductAffectedFixed in
Homebrewazure-clipkg:brew/azure-cliOther threatsAffected
  • >=2.59.0 <2.70.0
Fixed in
  • 2.70.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Red Hat has released an update for Red Hat Service Interconnect 1.4 for RHEL 9 and RHEL 8 that addresses these vulnerabilities. Users should apply this update after ensuring all previously released errata relevant to their system have been installed. Detailed update instructions are available at Red Hat's official documentation. No additional mitigation steps are indicated or required beyond applying the official update.

Description

pyca/cryptography's wheels include a statically linked copy of OpenSSL. The versions of OpenSSL included in cryptography 42.0.0-44.0.0 are vulnerable to a security issue. More details about the vulnerability itself can be found in https://openssl-library.org/news/secadv/20250211.txt. If you are building cryptography source ("sdist") then you are responsible for upgrading your copy of OpenSSL. Only users installing from wheels built by the cryptography project (i.e., those distributed on PyPI) need to update their cryptography versions.

References

Community reviews

Loading reviews…