SUSE · security update for redis
Affects SUSESource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · public detection template (Nuclei) : upgrade to 6.2.20 soon.
Data as of 26 Oct 2026, 06:26 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 3.9% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 6.2.20
Exploitation evidence
Disclosed: evidence found.
CVE published 29 Oct 2025
Detectable: evidence found.
nuclei template: Redis < 8.2.1 lua script - Integer Overflow
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade redhat/redis to 6.2.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/redispkg:rpm/redhat/redisOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available from Red Hat addressing these vulnerabilities. Users should apply the updated Redis packages for Red Hat Enterprise Linux 9 and related distributions as detailed in the Red Hat advisory RHSA-2025:19237. No additional mitigation steps are indicated beyond applying the official patch.
Description
Multiple security vulnerabilities have been identified in Redis related to its Lua scripting capabilities, including integer overflow, unauthorized script execution as different users, denial of service, and use-after-free leading to potential remote code execution. These issues affect Redis versions packaged with Red Hat Enterprise Linux 9 and related distributions. A security update addressing these vulnerabilities is available from Red Hat.
References
- access.redhat.com/errata/RHSA-2025:19237 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401258 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401292 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401322 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401324 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_19237.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_19237.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-October/002137.html (opens in a new tab)
- suse.com/security/cve/CVE-2025-46817/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-46818/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-46819/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-49844/ (opens in a new tab)