SUSE redis · security update for redis
Affects SUSE redisSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 4.7 Medium : upgrade the Red Hat redhat/redis package to 7.2.10 when convenient.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.2.10
CVSS:3.1/AV:L/AC:H/PR:L/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 29 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade the Red Hat redhat/redis package to 7.2.10.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Red Hatredhat/redispkg:rpm/redhat/redisOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A security update is available and should be applied promptly. Red Hat has released updated Redis packages (version 7.2.10 and later) that address these vulnerabilities. Users of affected versions (>=7.0.0 <7.2.10) should upgrade to the fixed versions as per the Red Hat advisory RHSA-2025:12008. Follow vendor instructions at https://access.redhat.com/articles/11258 for applying the update. No additional mitigation is indicated by the vendor.
Description
Multiple security vulnerabilities have been identified in Redis, an advanced key-value store used for in-memory data storage. These include a stack buffer overflow (CVE-2025-27151), an unauthenticated denial of service (CVE-2025-48367), and a Hyperloglog out-of-bounds write vulnerability (CVE-2025-32023). These issues affect Redis versions starting from 7.0.0 up to but not including 7.2.10. A security update addressing these vulnerabilities is available from Red Hat and SUSE for their respective Redis packages.
References
- access.redhat.com/errata/RHSA-2025:12008 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2369153 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2376857 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2376858 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_12008.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_12008.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-July/001853.html (opens in a new tab)
- suse.com/security/cve/CVE-2025-27151/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-32023/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-48367/ (opens in a new tab)