SUSE · security update for redis
Affects SUSESource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · public detection template (Nuclei) : upgrade to 7.2.11 soon.
Data as of 25 Oct 2026, 19:02 UTC
Rated by Threat Radar · No CVSS score from NVD or the CNA
- EPSS
- 3.9% chance of exploitation in 30 days – higher than 90% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 7.2.11
Exploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2025
Detectable: evidence found.
nuclei template: Redis < 8.2.1 lua script - Integer Overflow
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.
What to do
Upgrade SUSE to 7.2.11.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| SUSE Product Security Team SUSE | Affected
| Fixed in
|
AI-suggested
A security update is available and should be applied promptly. Red Hat has released patched Redis packages (version 7.2.11-1.module+el9.6.0+...) for Red Hat Enterprise Linux 9.6 and related distributions. Users should follow the update instructions provided by Red Hat in their advisory (https://access.redhat.com/articles/11258) to remediate these vulnerabilities. No additional mitigations are indicated beyond applying the official update.
Description
Multiple security vulnerabilities have been identified in Redis related to its Lua scripting capabilities. These include integer overflow leading to potential remote code execution (CVE-2025-46817), privilege escalation via execution of Lua scripts as a different user by authenticated users (CVE-2025-46818), denial of service through specially crafted Lua scripts (CVE-2025-46819), and a use-after-free vulnerability in Lua that may lead to remote code execution (CVE-2025-49844). A security update addressing these issues is available for Redis 7.2.11 on Red Hat Enterprise Linux 9.6 and related distributions. The update is rated as important by Red Hat Product Security. Users should apply the update to mitigate these vulnerabilities.
References
- access.redhat.com/errata/RHSA-2025:19345 (opens in a new tab)
- access.redhat.com/security/updates/classification/ (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401258 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401292 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401322 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2401324 (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/advisories/2025/rhsa-2025_19345.json (opens in a new tab)
- suse.com/support/security/rating/ (opens in a new tab)
- ftp.suse.com/pub/projects/security/csaf/rhsa-2025_19345.json (opens in a new tab)
- lists.suse.com/pipermail/suse-liberty-linux-updates/2025-October/002138.html (opens in a new tab)
- suse.com/security/cve/CVE-2025-46817/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-46818/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-46819/ (opens in a new tab)
- suse.com/security/cve/CVE-2025-49844/ (opens in a new tab)