Skip to main content
CVE-2024-14029VulnerabilityPublished Updated

Red Hat Security Advisory: RHOAI 3.5.2 - Red Hat OpenShift AI

Affects Red HatSource GCVE Database

0
Authoritative record:CVE-2024-14029· Critical 9.0

Not known to be exploited · CVSS 9.0 Critical : upgrade Red Hat tornado to 6.4.1 as a priority.

Data as of 26 Oct 2026, 17:08 UTC

CVSS 4.0 base score
9.0Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 29% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.4.1
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:L/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade tornado to 6.4.1.

Affected software

ProductAffectedFixed in
tornadowebtornadoAffected
  • <6.4.1
Fixed in
  • 6.4.1
PyPItornadopkg:pypi/tornadoOther threatsAffected
  • <6.4.1
Fixed in
  • 6.4.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version, Red Hat OpenShift AI 3.5.2, is available. Users are advised to upgrade their clusters following the official Red Hat documentation linked in the advisory to fully apply the errata update. No additional mitigation steps are specified or required beyond applying this update.

Description

Red Hat OpenShift AI 3.5.2 was released as a security advisory addressing multiple vulnerabilities, including CVE-2024-14029. The advisory announces updated images and provides upgrade instructions but does not detail specific fixes for CVE-2024-14029 or other listed CVEs. The advisory is marked critical in severity but does not confirm known exploitation in the wild.

References

Community reviews

Loading reviews…